Pipeline failed on deploy, URL missing ( typo), fixed but cannot complete pipeline

Hello,
I am a GITLAB newbie and our IT staff is overwhelmed and cannot help me at this time.

I have a web app that is in GITLAB and it is usually edited in Visual Studio and commited through Git Extensions but at the moment I cannot get that connection to function properly. (Another Story)

The IT staff showed me how I could modify the files I need to edit directly in GitLab.
So I tried this. basically I am editing a webpage and adding a link to a new file. I had to up load the file and know that I needed to add to the csproj file an include so the app would know to include the file.

I made the change in the web page to add the link.

Then I committed all that to the current develop branch. The file upload worked.
But I made a type in the csproj file. And the commit failed to deploy and that is where I saw the error.

So I fixed the typo and was required to commit again. This time the csproj file passed and seemed to deploy.

I assumed I needed go back to the pipeline that failed and see if I could get it to finally deploy. I tried the retry deploy but it did not work. I am wondering if I somehow had to edit what was the file that was trying to be committed or deploy.

The error " No URL provided, cache will not be downloaded from shared cache server. Instead a local version of cache will be extracted. " makes me think that this is another temporary branch that I should have fixed but I don’t know where this is if that is what I should have fixed instead where I did.

Basically how do I get the deploy to pass now?