Pipeline stuck in "preparing" on Kubernetes deployment

Our pipelines get stuck since this morning on “preparing”. Unfortunately, there’s no more information provided. All other pipeline steps get executed successfully on our kubernetes gitlab-runners.


1 Like

We have same problem with just one particular repository. On deploy stage.

Also experiencing this on the deploy stage of our kubernetes deployment from gitlab.com with our own kubernetes runners

We are experiencing the same, usually for jobs in the deploy stage

For us disabling the kubernetes cluster integration (we have our own deployment scripts, so it is not a problem) solved this issue

1 Like

yep that worked for us too, thanks @pp.koszta similarly we have our own deployment scripts so the integration isn’t useful

This might be du to this merge request: https://gitlab.com/gitlab-org/gitlab-ce/merge_requests/25586


Hey all, our apologies for the issues here. It looks like this was caused by a regression introduced in this MR.

We’ve temporarily disabled the feature flag on GitLab.com that caused this until a solution is found so everything should be back to normal.

Thanks, @adrien.montfort for the link to that MR.