Pipeline was not triggered after successful commits

It worked fine last Friday. Today new commits doesn’t trigger pipeline builds.

An example commit is (https://gitlab.com/xhq/docker-demos/dd-product-service/commit/78e14321627c1a11580b38036fd9b90c135ea128).

I manually triggered a pipeline build. (https://gitlab.com/xhq/docker-demos/dd-product-service/commit/cc75b92d9402839798591aa32cea55be84ae50fa/pipelines).

After some long time, the pipeline is stopping at pending status even at the job level the stage 1 is in passed status (https://gitlab.com/xhq/docker-demos/dd-product-service/-/jobs/33915927).

Anything wrong?

1 Like

I’m having the exact same issue at the moment in one of my repositories. I’ve pushed a new branch and every time I try to create a merge request it comes back saying the branch doesn’t exist, but I can see it there both through command line and web UI. Also the pipeline didn’t trigger and I tried manually like the OP but it’s still in pending state.

Yep, exactly the same thing here. Pushing to branches shows up in the remote branch but doesn’t trigger pipelines & commits don’t show up in any MRs. Also getting intermitted 500s when trying to load up MRs - some of which reported missing source branches which I know exist. Same thing with pipelines showing up as Pending when they’ve already failed. The new AutoDevops ‘feature’ suddenly becomes AutoBreakOps.

Looks like they’re having some issues. https://twitter.com/gitlabstatus/status/912364895320059904