Problem with cloning

Hello.
While cloning repo on Gitlab I’m getting this:
fatal: refusing to work with credential missing host field

Can it be git configuration issue?
Have you come across this post?

Hey Doc
I saw this post, but ```
sslbackend = openssl

This is my .gitconfig

# This is Git's per-user configuration file.
[user]
# Please adapt and uncomment the following lines:
	name = serhiibabiak
	email = serhii.babiak@dxc.com

[http "https://git.swf.daimler.com/"]
	sslCert = "C:/Users/SBabiak/.ssh/swf/swf.crt"
	sslKey = "C:/Users/SBabiak/.ssh/swf/swf.key"
	sslCaInfo = "C:/Users/SBabiak/.ssh/swf/swf-ca.crt"
	sslbackend = openssl
[https]
	sslCert = "C:/Users/SBabiak/.ssh/swf/swf.crt"
	sslKey = "C:/Users/SBabiak/.ssh/swf/swf.key"
	sslCaInfo = "C:/Users/SBabiak/.ssh/swf/swf-ca.crt"
[url "https://gitlab-ci-token:TOKEN@git.swf.daimler.com/"]
	insteadOf = ssh://git@git.swf.daimler.com:7999/
[filter "lfs"]
    smudge = git-lfs smudge -- %f
    process = git-lfs filter-process
    required = true
    clean = git-lfs clean -- %f

C:\Users\SBabiak>git clone ssh://git@git.swf.daimler.com:7999/swf/verification-robotframework.git
Cloning into ‘verification-robotframework’…
fatal: refusing to work with credential missing host field

I don’t know where this host field is

Hmmm, interesting
From my past experience, when it comes to dealing with ssl, if there is any mismatch anywhere then there would be an error.
Those crt files (and .key), are they correct?
have they ever worked?
can you clone other repos?
can others clone this repo?
I’d check the certs with keytool/openssl, or generate new ones? When you generate new one and create a crs there is a hostname field to fill in there, maybe that’s what’s missing from your current certs? I’m just guessing, but worth having a look

Thank you for the answer
I will try in this direction

1 Like

You’re welcome :slight_smile: Let us know how it goes

1 Like