Problem with group manage access

I have got one problem when i want change access for the one group.
I click “Manage access” and get error “500 Whoops, something went wrong on our end”
In logs i see
"Parameters: {“group_id”=>“TEST”}
Completed 500 Internal Server Error in 109ms (ActiveRecord: 14.6ms | Elasticsearch: 0.0ms)

ActionView::Template::Error (undefined method `name' for nil:NilClass):
114: data: { confirm: leave_confirmation_message(member.source) },
115: class: 'btn btn-remove prepend-left-10'
116: - else
117: = link_to member,
118: method: :delete,
119: data: { confirm: remove_member_message(member) },
120: class: 'btn btn-remove prepend-left-10',"

How can decide this problem?
Manage access other groups is ok.

I have the same issue on my instance, some missing vars in the template.
I pretty sure I have trigger the problem when I add some email invites
on the group.

I trigger the problem with Gitlab 11.10 but I upgraded to 12.3, the problem is still here.

Started GET "/groups/MYGROUP/-/group_members" for 78... at 2019-10-11 12:42:48 +0000
Processing by Groups::GroupMembersController#index as HTML
  Parameters: {"group_id"=>"MYGROUP"}
Completed 500 Internal Server Error in 414ms (ActiveRecord: 45.4ms | Elasticsearch: 0.0ms)
ActionView::Template::Error (undefined method `name' for nil:NilClass):
    117:                       data: { confirm: leave_confirmation_message(member.source) },
    118:                       class: "btn btn-remove align-self-center m-0 #{'ml-sm-2' unless force_mobile_view}"
    119:           - else
    120:             = link_to member,
    121:                       method: :delete,
    122:                       data: { confirm: remove_member_message(member), qa_selector: 'delete_member_button' },
    123:                       class: "btn btn-remove align-self-center m-0 #{'ml-sm-2' unless force_mobile_view}",
app/helpers/members_helper.rb:18:in `remove_member_message'
app/views/shared/members/_member.html.haml:120:in `_app_views_shared_members__member_html_haml___3784732443288793865_69892171233340'
app/views/groups/group_members/index.html.haml:50:in `_app_views_groups_group_members_index_html_haml__1958455918261859749_69892141548940'
app/controllers/application_controller.rb:118:in `render'
lib/gitlab/session.rb:11:in `with_session'
app/controllers/application_controller.rb:450:in `set_session_storage'
lib/gitlab/i18n.rb:55:in `with_locale'
lib/gitlab/i18n.rb:61:in `with_user_locale'
app/controllers/application_controller.rb:444:in `set_locale'
lib/gitlab/request_profiler/middleware.rb:17:in `call'
lib/gitlab/middleware/go.rb:20:in `call'
lib/gitlab/etag_caching/middleware.rb:13:in `call'
lib/gitlab/middleware/correlation_id.rb:16:in `block in call'
lib/gitlab/middleware/correlation_id.rb:15:in `call'
lib/gitlab/middleware/multipart.rb:117:in `call'
lib/gitlab/middleware/read_only/controller.rb:42:in `call'
lib/gitlab/middleware/read_only.rb:18:in `call'
lib/gitlab/middleware/basic_health_check.rb:25:in `call'
lib/gitlab/request_context.rb:26:in `call'
lib/gitlab/metrics/requests_rack_middleware.rb:29:in `call'
lib/gitlab/middleware/release_env.rb:12:in `call'

I solved this issue by deleting members email requests in the gitlab database.

  1. sudo /usr/bin/gitlab-psql
  2. DELETE FROM members WHERE invite_email != '';

I pretty sure this is a feature of the EE version not available in the CE edition which break the template because the user_id is empty.

Thank you so much.
I did these command i problem was solved.

1 Like