Problem with repository mirroring for forks

Hello, @dnsmichi I encounter an issue trying to mirror a repo and I think it is because after forking the repo I have a master in my fork and I created a branch called bole also in my fork.
Now I think there are two different branches namely master in my fork and bole in my fork.

While I was mirroring the repo, I check the box for Overwrite diverged branches and also Mirror only protected branches but my mirroring still fails.

What am I doing wrong? or can I restart the process all over again by forking again and mirroring then create a merge request?

Hi,

I’ve split your question into a new topic :slight_smile:

Can you share the error message you are seeing? Also, the configuration overview for mirroring would be interesting.

Starting over with deleting everything should work, although the problem itself being analysed could maybe unveil a bug.

Thanks & kind regards,
Michael


That was the error message not till one of the maintainers help me fix the issue by using his own test account in trying to mirror and it works so he suggested I check my password if it is correct or use SSH Key or I’d be ok with this test account doing my mirroring for a few weeks. Alternatively, I can read about updating Git forks manually from the command line, which is pretty common too.

So, I’m working on doing that - updating with Git after checking if my password is wrong.

Thanks for coming through

Hello
I’m still having this problem, I merged this into my fork, but unfortunately, that caused the fork to become diverged from the main repo again, so repository mirroring is failing again.
I have a fork called “master” and a branch “Bole”, I tried to revert the merge into bole as a branch but couldn’t find it while searching for it.
What should I do?


This is a recent issue that happens because I merged into my fork instead of the master fork causing the fork to become diverged. What should I do?

Can you share a link to the repo that is causing you trouble?

Thanks for the reply, here you go Dule Martins / GitLab · GitLab
And, this is the link the conversation between me and Marcel Amirault :interrobang: when he tried to help.
Update - All future tense with the present tense (!1) · Merge requests · Dule Martins / GitLab · GitLab And this is to the issue I was contributing to Fix Vale issues in ./administration/pages/index.md (#335324) · Issues · GitLab.org / GitLab · GitLab

I recommend the solution Michael proposed earlier: start over with a new fork and recreate the MR.

As an alternative, you can try visiting this URL to see if it will allow you to create an MR that merges the master branch of your fork into the master branch of the upstream repository.

We have an open issue related to the issue impacting you.

1 Like