Pull error for private image after docker login

In a pipeline that as worked for years, now I sporadically get some errors pulling images from the Gitlab registry.
I don’t know what I did wrong.

The job just look like this

centrogest:
  image: ictgroupdevops/sbt
  stage: build
  when: manual
  only:
    - ict-portal
  tags:
    - frank
  script:
    - export DOCKER_API_VERSION=1.35
    - docker login -u gitlab-ci-token -p $CI_BUILD_TOKEN $CI_REGISTRY
    - docker build --no-cache -t ${CI_REGISTRY_IMAGE}/${CI_COMMIT_REF_NAME}:centrogest --build-arg branch=$CI_BUILD_REF_NAME --build-arg rev=$CI_BUILD_REF --build-arg buildId=$CI_BUILD_ID --build-arg pipelineId=$CI_PIPELINE_ID --build-arg committimestamp=$CI_COMMIT_TIMESTAMP -f sorgente/docker/Dockerfile-centrogest-multi .
    - docker push ${CI_REGISTRY_IMAGE}/${CI_COMMIT_REF_NAME}:centrogest

During execution, the first command succeeds, printing “Login Successfull”, and than the second command start and gives us “Pull access denied”, I attach a screenshot to clarify.

I we restart the pipeline right after it fails it keeps giving the same error again, but if we wait just 5-10 minutes everything goes fine.
Is there a problem with the gitlab registry?

We are using Gitlab.com, not a self-hosted version.
We are using a group runner with a recent version, 13.8.0

Thank you