Pushing merge to master fails (Failed to authorize + 502 error in web interface)



we worked for one month on our develop branch and now for the release we wanted to merge down to master. However gitlab now gives the following error when I try to push the newest master:
remote: GitLab: Failed to authorize your Git request: internal API unreachable
To gitlab.com:xxxx
! [remote rejected] master -> master (pre-receive hook declined)
error: failed to push some refs to ‘git@gitlab.com:xxxx’

After several tries I thought maybe this is a local issue and went to the GitLab web interface. There I wanted to create a Merge Request where I selected develop to master. However when i click “Compare branches and continue” it loads quite a long time and then it shows me a 502 error (GitLab not responding). This tells me that there is something wrong on server side.

No fancy setup, no protected branches, nothing… and it worked a month ago.

Hope someone can help here.

Best regards


I fixed it now by:

  1. branching master to master_new
  2. pushing to master_new
  3. setting master_new as new default branch
  4. deleting old master branch
  5. renaming master_new to master

But still strange that it didn’t work anymore with the old master branch.


For what it’s worth, I was able to resolve this just by doing an unnecessary pull, then pushing again.