Readiness probe failed: Get dial tcp connect: connection refused Back-off restarting failed container


We have created the gitlab CI pipeline to automate the build and deployment process.

I my gitlab pipeline i added build,test, quality check, review and deployment stages. currently i stuck on deployment stage. my pipeline is getting succeeded till deployment but when i logged in on AKS their pods are not in running stage. its showing back-off pull error. we troubleshoot in depth and found that due to authentication issue it is not able to pull the image from ACR to AKS.
so basically for running the application we should have to create few secrets which we created and verified on AKS.
now we want those secrete system variables should be called from .gitlab-ci.yml file for that kindly share me the steps how i can call the deviceManagerDeployment.yaml file from .gitlab-ci.yml file which is in same directory.

please refer the error on attached image.


I think you are looking for the include directive: (but I may be wrong)

Tried with include as mentioning below-
- local: ‘

but getting error like this-

if you enter a complete url, you should use


instead of local or change the location to relative in the repository (if it is in the same repository) as explained in

also, apparently there’s something wrong with the yaml (I think you might need double quotes), not a real yaml expert

yeah, im just started and beginner in yaml. so i tried to with double quotes but still getting the same error.
please refer the below snip-

Looking at the examples the quotes shouldn’t be a problem sorry for that misdirection. But if you include it as a remote file, it will access the gitlab page, were I think you need the raw version (link is available on the file’s page).

Actually instead of calling the separate yml file i given those values on same file. so now that issue got fixed, but not sure why im getting the below error now-

please share your inputs to fix this.