Remote: You are not allowed to upload code

Starting this morning when attempting to push code to a repository that I have had no problems comitting or pushing code to before began giving me the following:

git -c diff.mnemonicprefix=false -c core.quotepath=false --no-optional-locks push -v --tags --set-upstream origin ds/features/email-event-blast-management:ds/features/email-event-blast-management
remote: You are not allowed to upload code.
fatal: unable to access 'https://gitlab.com/redacted/redacted.git/': The requested URL returned error: 403

Pushing to https://gitlab.com/redacted/redacted.git
Completed with errors, see above.

I have checked repo permissions (I am a maintainer for this project, only master is a protected branch), Sourcetree permissions, Git configuration. Reset my password on GitLab, changed in Sourcetree. Cloned the repo fresh to a new directory after changing password - and continue to get the same errors. Nothing I have tried so far has resolved the issue.

I’ve done a lot of Google searching but all I find are issues with protected branches, where the error message displayed is different (you are not allowed to upload to a protected branch), but nothing on this specific error.

Any ideas on anything else I should try?

EDIT: Note I have no problem committing or pushing to any other repo using the same account on GitLab. This only seems to apply to this specific repository.

EDIT2: I re-installed Git using the latest version and tried to push from the command line and get the same issue. This is driving me nuts! :stuck_out_tongue:

Hi! Can you open an issue in https://gitlab.com/gitlab-com/support-forum/issues? Seems something wrong with the particular project, we’d need more info to check it out.

You can mark the issue as confidential if this is a private project.