Repository does not exist

Hi there, i have an issues all my repositories are not available, the situation happened after i ran gitlab-ctl reconfigure. On my dashboard i can see the name of the projects, but i can access. when i access via ssh, inside on /@hashed there are all my repo .git. How can i re link my projects?

GitLab Version 13.04

GitLab version 13.04 is vulnerable to CVE-2021-22205. CVE-2021-22205: How to determine if a self-managed instance has been impacted

It is possible that a malicious actor exploited CVE-2021-22205 to corrupt your repository data.

Do you have a recent backup of your GitLab data?

I copied the info of our GitLab server.

GitLab 13.5.4 (7f5f940041c)
GitLab Shell 13.11.0
GitLab Workhorse v8.51.0
GitLab API v4
Ruby 2.6.6p146
PostgreSQL 11.9

I don’t believe that our issue has link with some exploit. Let’s me explain better.

Our projects lost the link with their repositories. So i have 72 projects without repository, but all repositories are in /var/opt/gitlab/git-data/repositories/@hashed/. Could you tell me how i could link my projects with the repositories?

Could you help me?

Hi @jyapur .

GitLab 13.5.4

Unfortunately your GitLab version (13.5.4) is vulnerable to CVE-2021-22205.

For more details, refer to:

If you run ls -al /var/opt/gitlab/git-data/repositories/@hashed/*/*/*.git on the GitLab server, do you see any suspicious files? (eg. files that end in .locked or .html?) If so, your server has likely been compromised and I encourage you to revert to a backup of GitLab data taken before this issue occured.

See also:

Perfect let’s me check this.

Hi there, again, i confirmed that our server is compromised with the exploit, so we have the backup before the attack, you suggest make fresh install and after we should restore the backup, Will my backup work on the last version? in case that the answer will be no, how i could resolved the issue?

Hi @jyapur

You can only restore a backup to exactly the same version and type (CE/EE) of GitLab on which it was created.

We have detailed instructions on how to backup & restore here:

If you have any questions not answered there, let me know!

thank for you help

1 Like

Hi Greg,

I’m having the similar issue and I don’t see any unusual files in the mentioned directories. Can you please help me with this?


Well, If you have a save backup, you could make these:

1- Make a zero installation, but choose the correct version that your last backup worked, from here you could find how you could make it: gitlab/gitlab-ce - Packages ·

2- Restore the backup, make sure that your server are not online, because, it is probably that your ip or firewall could get another attack

3- verify if everything is ok

4- Follow the instruction to run the upgrade to the last version, source: Upgrade GitLab by using the GitLab package | GitLab

I hope that i could help you.

1 Like