Running pipeline on an old tag gives workflow rules error

I’m using a self-managed Gitlab instance running version 12.7.6.

I have a tag which is about 2-3 years old which I would like to run a pipeline on. When I try to do this (by going to Pipelines, Run Pipeline) I get a red banner above indicating,

The form contains the following error:

  • Pipeline filtered out by workflow rules.

See the screenshot:



I’m not using any variables. The pipeline will run on master but not this branch.

I’ve tried:

  • using the instance root user to run the pipeline
  • running a health check on the project (it passes)
  • googling the error message
  • running the pipeline directly via the API
  • deleting any jobs which had a branch with the same name (which I did have in this repo at one stage)

I’d appreciate any suggestions and am happy to provide further information.

Scratch all that, I think at this stage there was no CI setup. How embarrassing !! :blush: Apologies for the spam.

I faced this issue too. I set up my CI with a bash template. I tried creating new projects as well, the same issue when I try to run a pipeline. I appreciate help here.