Self hosted community gitlab on k8s on prem - did you do it?

Hi guys,

Just wondering did any once succeed in deploying gitlab CE on k8s on prem?
We tried on AWS - worked like a charm using the charts provided…
then we tried on prem - and we are encountering very heavy difficulties…

happy to hear from you : )

Hi @achisolomon,
I’ve not set it up on-prem myself, but I’d love to help troubleshoot and figure it out.
On-prem or bare-metal Kubernetes can be complicated, especially when it comes to networking. These headaches are part of the reason so many people to pay for managed Kubernetes as a service (like AWS).

  • What difficulties are you encountering?
  • Are you installing it on top of an existing/working K8s instance, or were you building from scratch for this use case?
  • How many nodes and bare-metal servers are you looking to have in your k8s cluster?

Best Regards,
Greg M

Hi greg,

we manged to get it working, however once we del a pod ( especially gitaly or unicorn ) the git labs returns 404 in a in-consistent manner - any idea? ( we see in the gitaly logs “permission denied” response from unicorn…