Setup Error 5 for U2F Device

I have trouble to setup my yubikey as U2F-Device.
I get allways the following error:

There was a problem communicating with your device. (error code: 5)

Can someone help me with that please?
Thanks already!

I am having a similar issue. In Chrome I receive:

There was a problem communicating with your device. (error code: 2)

In Firefox 67.0 I get nothing but:

Trying to communicate with your device. Plug it in (if you haven't already) and press the button on the device now.

Using MacOS 10.14.5 and tested with a Yubikey 4 and Yubikey 5. I am using the gitlab/gitlab-ce docker images, image b3a3f6564d33 which is GitLab 11.10.1. I am using Caddy as a proxy server if that makes any difference.

i am getting the same errors on my self hosted install, nothing in javascript console or logfiles

makes no difference if the key is plugged in or not.

key works on the yubikey demo and other sites including the main site.

tried with 4c and 5c nano

this looks like for some reason my gitlab install is is not setting up the page correctly to work with the key.

Interesting, is it working for you on the main page? This does not work for me as well!
Tried yubikey 4 and 5NFC, also no output on console…

yes the key works fine in the same browser on

I’ve updated the local install (ubuntu via apt get ) to the current latest version and still not difference.

I see nothing in the log files from this.

Happy to dig deeper into this but I would help to have some guidance from the devs , I know ruby and linux well and have research time to get this working for a major org.

Can you tell me on wich OS/Browser (including version) you are working?

using chrome on macOS Mojave , updated yesterday.

I realised what the problem was , the site was running in http mode behind my https proxy.

once I installed the certificates into nginx it worked fine.

it would help if the UI could grey out the U2F button in http mode
this is already done with other prerequisites.

1 Like