Shared windows runner does not execute my newly built executable

Hello, I am trying to set up an automated build system for my game, which I compile with MSVC C++ compiler via command line. I am using a windows shared runner. This exact same system previously worked on Azure Devops, but I would like to have everything in Gitlab CI. The build process goes like this:

  • First step is to build the asset generator. Asset generator is a small console program that generates an asset package and a .h file from assets on the filesystem.

  • Second step is to run the newly built AssetGen.exe from shelll (This is the part where nothing happens. No error, nothing. I even tried to replace the AssetGen program by Hello World).

  • Third step is to build the game, with stuff generated by AssetGen.exe.

Here is my yml file, which is a slightly modified version of the windows shared runners template:

  - shared-windows
  - windows
  - windows-1809

  - build
  - deploy

 - Set-Variable -Name "time" -Value (date -Format "%H:%m")
 - echo ${time}
 - echo "started by ${GITLAB_USER_NAME}"

  - .shared_windows_runners
  stage: build
  - echo "running scripts in the build job"
  - ./ci_build.bat
    - Build/**/*

And here is ci_build.bat

set LibFlags=user32.lib  opengl32.lib Gdi32.lib Winmm.lib 
set IncludeFlags=-I%~dp0Src -I%~dp0Lib/Inc

call "C:\Program Files (x86)\Microsoft Visual Studio\2019\BuildTools\VC\Auxiliary\Build\vcvarsall.bat" x64

echo Creating folders...
call mkdir Build
call cd Build
call mkdir Data
call cd..

echo Done!

echo Building asset gen...
call cl -Zi -FC -FeAssetGen.exe %IncludeFlags% %WPFlags% -Oi -Od %~dp0Src/AssetGen/wp_assetGen.cpp -wd4530 /link %LibFlags% -SUBSYSTEM:CONSOLE

echo Done!

echo Calling assetgen...

call AssetGen.exe Dev/Data/ Build/Data/wp_Data.pkg Src/IO/wp_resourceInfo.h

echo Done!

echo Building Game...
call cl -Zi -FC -FeBuild/WorstEngine.exe %IncludeFlags% %WPFlags% -Oi -Od %~dp0Src/Platform/Windows/wp_winMain.cpp /link %LibFlags%

echo Done!

Nothing happens when I call assetgen. What am I doing wrong? As I said before, exact same thing worked on Azure Devops.