Slack integration gives 502

I’m trying to set up slack integration, using Gitlab 8.9.2. I set up a webhook on Slack, added a small text file to my repository (just to have something there) and tried setting up a Slack integration for my project. However, when I click “test settings”, the browser just waits a bit and shows me a 502 error page after a while. No messages are coming through to Slack when I add/change issues etc in Gitlab either.

What could be the problem?

A little more information: I have the following in /var/log/gitlab/gitlab-workhorse/current (replaced personal info with MYPROJECT and MYHOSTNAME). So proxyroundtripper fails because of EOF?

2017-03-27_06:41:45.09725 2017/03/27 08:41:45 error: proxyRoundTripper: GET "/MYPROJECT/services/slack/test" failed with: "EOF"
2017-03-27_06:41:45.09729 2017/03/27 08:41:45 ErrorPage: serving predefined error page: 502
2017-03-27_06:41:45.09731 MYHOSTNAME @ - - [2017-03-27 08:40:44.471094607 +0200 CEST] "GET /MYPROJECT/services/slack/test HTTP/1.1" 502 2192 "https://MYHOSTNAME/MYPROJECT/services/slack/edit" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.88 Safari/537.36 Vivaldi/1.7.735.46" 60.624112

I upgraded to version 9.0.0, and now it works.