[SOLVED] 502 Gitlab is not responding

I 'm despair. I am trying to install gitlab for 3 days without success on my RaspberryPi 2 with Debian (1024 MB RAM, quad core ~ 800MHz). I was following this guide at the newest version of gitlab (7-8-stable). I also installed the newest ruby version 2.2.1. If I ran sudo -u git -H bundle exec rake gitlab:check RAILS_ENV=production all fields are green so the installation should be correct. The unicorn.stderr.log puts the error:

E, [2015-03-10T11:17:31.655757 #12035] ERROR -- : reaped #<Process::Status: pid 12047 SIGABRT (signal 6)> worker=1
I, [2015-03-10T11:17:31.689622 #12146]  INFO -- : worker=1 ready

I saw in the troubleshooting guide that I have to precompile the assets with sudo -u git -H bundle exec rake assets:precompile RAILS_ENV=production, what I have done, but the error is still there.

The only error in the production.log file is

PG::Error: ERROR:  database "gitlabhq_production" already exists
: CREATE DATABASE "gitlabhq_production" ENCODING = 'unicode'
PG::Error: ERROR:  database "gitlabhq_production" already exists
: CREATE DATABASE "gitlabhq_production" ENCODING = 'unicode'

and makes no sense for me. Here is the sidekiq.logfile. I already set the timeout in the unicorn.rb file to 360.

A possible trouble could be the domain setting. I test gitlab in my local network so in every config I let the localhost option.

I test gitlab with a static local network ip 192.168.1.x. Later I want to have access with the no-ip service and an domain like xx.no-ip.org. What should I write for

# Update GitLab config file, follow the directions at top of file
sudo -u git -H editor config/gitlab.yml

or in the nginx configuration. What is my fully qualified domain name?

I think the problem lies here:

E, [2015-03-08T12:36:19.560253 #2751] ERROR -- : reaped #<Process::Status: pid 2779 SIGABRT (signal 6)> worker=2
I, [2015-03-08T12:36:19.583573 #2878]  INFO -- : worker=2 ready

but I don’t know how I can fix the problem.

It could be that ruby had some problems as the log shows after the sudo -u git -H bundle exec rake assets:precompile RAILS_ENV=production command:

/home/git/gitlab/vendor/bundle/ruby/2.2.0/gems/activesupport-4.1.1/lib/active_support/values/time_zone.rb:285: warning: circular argument reference - now
/home/git/gitlab/vendor/bundle/ruby/2.2.0/gems/fog-core-1.21.1/lib/fog/core/collection.rb:148: warning: circular argument reference - filters
/home/git/gitlab/vendor/bundle/ruby/2.2.0/gems/fog-1.21.0/lib/fog/rackspace/mock_data.rb:43: warning: duplicated key at line 81 ignored: "name"
/home/git/gitlab/vendor/bundle/ruby/2.2.0/gems/therubyracer-0.12.0/lib/v8/function.rb:13: [BUG] Segmentation fault at 0x30c124
ruby 2.2.1p85 (2015-02-26 revision 49769) [armv7l-linux-eabihf]

Can someone please help me?

Finally I have it! https://github.com/gitlabhq/gitlabhq/issues/8809

1 Like

Hi @Chryb ! I’m glad you found my issue on Github. For those who did not read the full thread, GitLab 7-8-stable is working fine on Raspberry Pi. Follow the installation guide, but before instal Gems step, follow these instructions:

  • Install or compile Node.js from sources. Ensure you are up-to-date (tested on node v0.20.0).
  • Run the following command in your GitLab’s installation folder :
sed -ri '/therubyracer|libv8|ref/d' Gemfile{,.lock}
```
This will basically remove `therubyracer` and `libv8` dependencies from your `Gemfile` and `Gemfile.lock` files.

- You can then continue installation as noted in the [installation from sources instructions](https://gitlab.com/gitlab-org/gitlab-ce/blob/master/doc/install/installation.md), or eventually hit it with
```console
bundle install --no-deployment --without test development
```
I hope this TL;DR helped, for further information, please check the original issue on [github](https://github.com/gitlabhq/gitlabhq/issues/8809).

Jordan

Hello @habovh,

I tried to install Gitlab CE (10.3 or 10.0.3?) on a Raspberry Pi 2. And after all steps with the omnibus package I also get a 502 not answering fast enough. I cd into the /opt/gitlab folder and tried Your command but it seems like there are no gemfiles. What kind of debug output could I show You to analyze the cause of this problem?

1 Like