[SOLVED] 7.9rc1 regression - cannot save project on gitlab.com

It’s quite weird that when I tried to create a new project today only to be notified with a message saying that “Can’t save project. Please try again later”.

Is the GitLab online under maintenance? I cannot find any notice on the service status on the official site. Note that I’m using the hosted version of GitLab, so there shouldn’t be any problem with my config, should it?

Got the same Problem by trying to create a project on the website since 4 hours now. i think there is something wrong atm.

Same issue for the past 6 Hours

Same here…

Thanks for reporting guys.

Opened issue: https://gitlab.com/gitlab-org/gitlab-ce/issues/1247

I also reported it to the regression one: https://gitlab.com/gitlab-org/gitlab-ce/issues/1241#note_985910

This is now resolved on gitlab.com.

Good to know. :slight_smile:

I wrote a short post mortem for this bug so you can see what happend :smile: :

  • 2015-03-18 05:00 (UTC) v7.9rc1 is released and deployed to gitlab.com
  • 2015-03-18 10:00 (UTC) facadev notices the bug and reports it to the community forum
  • 2015-03-18 12:00 (UTC) @axil sees the forum entry, creates an issue and informs the core team
  • 2015-03-18 13:00 (UTC) first attempts at locating the error are made by @haynes and @DouweM
  • 2015-03-18 14:00 (UTC) @sytses wakes up and informs @marin
  • 2015-03-18 14:40 (UTC) @marin starts looking into the issue
  • 2015-03-18 14:48 (UTC) @marin fixes the issue on gitlab.com

In total the issue was active on gitlab.com for ~10 hours
and it took ~5 hours from the creation of the bug report to fixing it.

3 of those 5 hours were spend sleeping by half of the team because of the different time zones.

To ensure that the response time is faster in case something like this happens again, @DouweM now has an emergency mail address he can use to wake up @sytses and @dzaporozhets

It’s still being investigated how the bug could pass the gitlab test suite without being noticed.

1 Like