[SOLVED] Assigning a merge request - no users found

Has anyone else seen an issue on GitLab.com where you go to assign a merge request to a user and there are none? I can only assign it to me.

It used to work properly for this project. I’m merging from a branch on one for to a branch on the main fork.

Ok - it seems to be working now. Odd.

I guess, I have a similar problem. What did you change?

Nothing, it still happens from time to time. Don’t assign it to anyone, then go back to it after and assign someone, the list will populate. Just be sure not to hit the close or submit button because that acts on the merge request. Changes happen instantly.

So, your issue is not solved at all?

I believe this is by design and could be improved.

The thing is that when performing an MR from your fork, you don’t have the right permissions on the upstream project, so the assign list shows only you, the owner of the fork. When you submit the MR, it is now part of the upstream project so you can assign it to the members of the repo.

So there was a similar post and as it seems this was a bug and fixed in master. Next release will have the fix included. See

Hi, @axil,

thank you for your clarification. The referenced issue is from me as well. :wink:
I patched my installation (currently using 7.11.4) with the supplied patchset and it works quite fine.