[Solved] Binding gitlab to ipaddress on debian

Firsttime install on debian (10.3) using latest stable omnibus install. Simple http, no https.

Fail: I missed the fact, my pihole already took port 80

  • setup second ip address (done)
  • bound piholes lighthttpd to first (done)
  • move gitlab to secondary ip address (stuck)

What i did so far:

sudo gitlab-ctl reconfigure
sudo gitlab-ctl start
ok: run … (all 15 services up)

netstat -npl

  • firstip:80 lighthttpd pihole-ftl
  • scndip:80 nginx

This far, this nice … but browsing http//gitlab.mydomain results in:

502 Whoops, GitLab is taking to much time to respond
(Which happens instantly)
Btw.: Before moving nginx to another ip address, gitlab showed up the configuration page at this point…

I’m new to gitlab, so any help is welcome.
Which of the many logfiles would help best in resolving this issue?


I just did a maintenance reboot of the ms v-host running the debian vm. This did reboot the debin vm too…
Gitlab configuration page now shows up on secondary ip.
Problem solved. Sorry for the previous post.