SOLVED: Had to retire a domain, new domain is named same but it won't link logins to the "new" AD from "old" accounts

This is probably a weird case. I had GitLab authing to my Samba AD, and then had to create a new domain on a new server because the old Samba VM got corrupted. Everything is the same – same usernames, same sAMAccountNames, etc. but when I log in as “starkruzr” I get a “brand new” account and it says my account @ is “starkruzr1” instead of “starkruzr.” How do I fix this mapping? Where is it located?


ETA: Figured this out myself. The mapping between users and DNs is in the “identities” table in the Gitlab Postgres instance (accessible via gitlab-psql). My DNs were different because I had switched to Samba and it builds them differently. So I deleted the new one and put its DN into the DN field for the “old” user identity. Poof, it works!

1 Like

Poof! :sparkles: Love when that happens!

Thanks for coming back and letting us know how you solved for this, @starkruzr! Hope to see you more around the community forum! :blush: