[Solved] Restarted GitLab pods, not longer able to create new files in project?

Hi, was wondering if anyone has a suggestion on this. Have been running GitLab CE 13.6 (yeah, I was going to upgrade next week) fine for a while on an in-house K8s platform. This week we had some maintenance, and all the pods got restarted/moved. Afterwards everything seemed fine. Can log in, browse, schedules running… but, if I try to create a new project, I’m not able to add new file. Can’t even initialize if with a readme.

I’ve obviously checked all pods are running, restarted them again, checked kubernetes logs on the pods, and as far as I can tell it all looks good. Any suggetions where to look next?

As tradition has it, shortly after posting this, the issue was resolved. I tried to recreate the three ingress objects (gitlab-ext-minio gitlab-registry gitlab-webservice) in front of the services, and that threw an error " Internal error occurred: failed calling webhook “validate.nginx.ingress.kubernetes.io” "

As a workaround I ran “kubectl delete -A ValidatingWebhookConfiguration ingress-nginx-admission” as following https://github.com/kubernetes/ingress-nginx/issues/5401 thread.

And then recreated some of the pods (registry, gitaly). Still investigating, but hopefully this information may help someone in the future.