[SOLVED] Shouldn't apt-get/yum install the latests stable instead RC?


Last sunday I wanted to upgrade my Gitlab instance from v7.10.1 to v7.10.4.
I also wanted to “convert” my instance to a package installation. So I ran these commands:

curl https://packages.gitlab.com/install/repositories/gitlab/gitlab-ce/script.deb.sh | sudo bash
sudo apt-get install gitlab-ce

And that got my instance upgraded to v7.11.RC2. A release candidate …
Not a big issue for my private instance, but at work we prefer stable releases.

I know I could have specify a version like sudo apt-get install gitlab-ce=7.10.4~omnibus.1-1
But shouldn’t apt-get install the latest stable version, v7.10.4, if no version is specified?

Yes, this is a known issue. See the blog post that explains it https://about.gitlab.com/2015/04/22/gitlab-7-10-released/

Update on package server issue

The problem below only occurred with apt-get installations before 7pm UTC on April 22, 2015.

Due to a problem with the package server, the release candidate was seen
as newer than the 7.10 stable release and got installed on some machines instead.

If your instance is running the release candidate, rather than the stable version,
you will need to bypass the version check and explicitly install the new GitLab
version. Use the commands below:

sudo apt-get install gitlab-ce=7.10.0~omnibus-1
sudo yum install gitlab-ce-7.10.0~omnibus-1.x86_64

So, bottom line is that switching to a repo installation from 7.10, you need to explicitly tell apt the version. From there on it should pick the stable versions.

thanks for the info!