Stuck in MFA hell

Don’t know what changed in gitlab.com but I’m unable to do anything with my MFA settings. I have a new phone and would like to disable/enable, and while I get no errors, it’s completely impossible to disable MFA.

I’ve also disable MFA requirements from any groups I own just in case this was the issue. Nothing.

I’m unable to manage the MFA status of my account. To be clear: I have nothing but an empty group in gitlab.com. No repos, nothing. I just have an empty account that I would like to not lose due to this ridiculous bug (judging by google searches, this is happening a lot).

There literally isn’t anything else I can add. No errors. No warnings. After I click on “Manage 2 factor” I enter my password and click on “Disable”. No errors. Just a silent fail.

Bumping this! Because of this I’ll lose access to my account as I have to give the cellphone that currently holds the OTP and there’s NO WAY TO CHANGE IT.

Can’t this be replicated by anyone else? Is there no support for users of gitlab.com outside of these forums?

Hi,

I just created myself a test account on gitlab.com and was able to enable MFA and also disabled MFA by entering my password. Not sure what browser you are using, but perhaps try using a different one. Worked for me in Brave. Maybe try a private/incognito session or make sure you have any plugins disabled.

Outside of these forums, as far as I know there is only Gitlab Support but this depends on you having a premium subscription or higher to get support. If you have a free account, then only these forums and community members offering assistance where possible, like myself.

Now I just feel stupid! Thank you @iwalker ! I was in Safari. Worked with Chrome.

Sorry for the noise but I never assumed it would be a browser thing.

I appreciate you taking the time.

1 Like