Translations missing when migrating from 10.8.5-ee to 11.8.6-ee

Hi,

When user language preference language is set to English, everything work’s fine. But when we switch user language preference language to French : we got an error 500 server when displaying the homepage

Here is the server log content :

Started GET “/profile” for XXX.XXX.XXX.XXX at 2019-08-27 15:10:04 +0000
Processing by ProfilesController#show as HTML
Completed 200 OK in 403ms (Views: 359.8ms | ActiveRecord: 9.3ms)
Started GET “/help” for 127.0.0.1 at 2019-08-27 15:10:09 +0000
Processing by HelpController#index as /
Completed 200 OK in 428ms (Views: 417.5ms | ActiveRecord: 0.9ms)
Started GET “/” for XXX.XXX.XXX.XXX at 2019-08-27 15:10:15 +0000
Processing by RootController#index as HTML
Completed 500 Internal Server Error in 130ms (ActiveRecord: 13.5ms)
ActionView::Template::Error (translation missing: fr.time.formats.timeago_tooltip):
11: - css_class = ‘’ unless local_assigns[:css_class]
12: - css_class += " no-description" if project.description.blank? && !show_last_commit_as_description
13: - cache_key = project_list_cache_key(project)
14: - updated_tooltip = time_ago_with_tooltip(project.last_activity_date)
15: - css_controls_class = compact_mode ? “” : “flex-lg-row justify-content-lg-between”
16:
17: %li.project-row.d-flex{ class: css_class }
app/helpers/application_helper.rb:133:in `time_ago_with_tooltip’
app/views/shared/projects/_project.html.haml:14:in _app_views_shared_projects__project_html_haml__3958484739225955321_70032864948300’

It seems that fr.time.formats.timeago_tooltip variable is missing in french translation. We tried to add the variable in the french locale file :

Then we reconfigured and restarted gitlab instance, still the error 500.

After that, we tried to change source code like this :

This workaround fixes the problem but it’s not the best way

Does this ring a bell with anyone? Any ideas?

Thanks!
Damien

1 Like

FYI Gitlab update fixed our problem

1 Like