Troubleshooting GitLab EE / Google omniauth SSO -- no Google logo on GitLab login screen

Hi! I just installed GitLab EE (10.5.1) and, in order to play with CI/CD deployment to a Kubernetes Cluster stuff, I tried to set up Single-Sign On integration with Google.

I followed all the instrations on /help/integration/google but I don’t see the Google logo on my login page.

There are no error messages.

How do I troubleshoot?

My gitlab.rb reads:

gitlab_rails['omniauth_enabled'] = true
gitlab_rails['omniauth_allow_single_sign_on'] = ['google_oauth2']
gitlab_rails['omniauth_auto_sign_in_with_provider'] = 'google_oauth2'
gitlab_rails['omniauth_external_providers'] = ['google_oauth2']
gitlab_rails['omniauth_providers'] = [
  {
    "name" => "google_oauth2",
    "app_id" => "[my id]",
    "app_secret" => "[my secret]",
    "args" => { "access_type" => "offline", "approval_prompt" => '' }
  }
]

I found the Troubleshooting Guide (Troubleshooting guide wiki) but the instructions there didn’t work (see my post at https://groups.google.com/forum/#!topic/gitlabhq/8GSLXW9MdUk)

I’ve verified my ownership of the domain my GitLab site is on in Google Search Console.

One more thing – /help/integration/google says:

From the Dashboard select ENABLE APIS AND SERVICES > Compute > Google Container Engine API > Enable

However, I don’t see “Google Container Engine API” under “Enable APIs and services”. I see “Google Container Registry API” and “Google Kubernetes Engine API” (which are both enabled), but there is no “Google Container Engine API”.

I see a hit to the “Google Compute Engine API” in the Google cloud console after I log out of GitLab and the login screen comes up – presumably GitLab is talking to Google at that time.

I also found https://gitlab.com/help/administration/troubleshooting/debug.md but didn’t see anything in there that I could use to understand why the Google logo is not showing up in my login screen.

I then wandered over to https://github.com/zquestz/omniauth-google-oauth2#omniauth-google-oauth2-strategy which said to enable “Google Contacts API” and “Google+ API”. So I enabled them both. Still no Google logo on my sign-in form…

When I go to CI/CD -> Kubernetes settings on my project, it says:

Google authentication is not properly configured. Ask your GitLab administrator if you want to use this service.

I tried running tcpdump and I don’t see any network traffic to Google when I bring up the login form. I don’t see any more traffic to the Google APIs either (in the Google UI).

Is there any way to turn on logging for omniauth? Or how do I troubleshoot further?

Thanks!
Aleksey