Trying to delete/block/deactivate a user throws 404

Hello,
There is a user in my gitlab omnibus installation (12.8.1) which is throwing 404 when I try to edit, delete, deactivate or anything else.
I’ve tried with 2 different admin users, also I’ve checked production logs to find out about user creation but there is no logs for that user name.
I can’t understand why this is happening and I cant get more logs.
below is the gitlab production logs when I try to delete that user.

Started GET "/admin/users/alert-bot/edit" for 79.**.**.18 at 2020-03-01 18:33:41 +0330
  Parameters: {"id"=>"alert-bot"}
{"method":"GET","path":"/admin/users/alert-bot/edit","format":"html","controller":"Admin::UsersController","action":"edit","status":404,"duration":186.8,"view":24.96,"db":93.44,"time":"2020-03-01T15:03:41.278Z","params":[{"key":"id","value":"alert-bot"}],"remote_ip":"79.**.**.18","user_id":2,"username":"arash","ua":"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.122 Safari/537.36","queue_duration":3.19,"correlation_id":"BvpPnSohW78","cpu_s":0.10255561399999996}
{"correlation_id":"BvpPnSohW78","duration_ms":197,"host":"git.****.com","level":"info","method":"GET","msg":"access","proto":"HTTP/1.1","referrer":"https://git.****.com/admin/users","remote_addr":"79.**.**.18:0","remote_ip":"79.**.**.18","status":404,"system":"http","time":"2020-03-01T18:33:41+03:30","uri":"/admin/users/alert-bot/edit","user_agent":"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.122 Safari/537.36","written_bytes":29719}
79.**.**.18 - - [01/Mar/2020:18:33:41 +0330] "GET /admin/users/alert-bot/edit HTTP/1.1" 404 6400 "https://git.****.com/admin/users" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.122 Safari/537.36"

thanks.