Unable to clone my private repo with credentials via URL

I’m having a weird problem with private repo authentication. Trying to clone a repo with GitKraken. Can’t pull LFS on the repo because it fails authentication. Tried connecting GitLab to GitKraken with oauth, and I tried cloning over standard https. The repo will clone both ways in GK, but will always fail authentication when pulling LFS. Cloning in the CLI using GitBash for Windows from GL over https, the repo will always fail authentication in general.

This make no sense why it’s failing authentication. I’m using Windows Credential Manager to store the GL username and password. I have cleared it multiple times and I know I’m using the correct login. It’s the same login for my GL cloud account, and I know it works.

So what’s up with this? I don’t understand why my git clone is failing authentication. Is there some kind of auth server over at GL that’s down?

So everything works when I set the repo from Private to Public. But I obviously don’t want this to be a Public repo.

So I think I am going mad.

Setting the repo from private to public, then back to private solved all the issues.