Unable to install the certmanager in kubernetes (group) cluster

I wanted to use the public GitLab more instead of my private hosted one, because I have (more or less) no reason to stick to my private one. So I started by creating a new group, a new kubernetes cluster and I added my cluster to that group as a group cluster. I then continued with installing all kinds of applications (helm tiller, ingress and a runner) which worked without any problems except for the cert manager.

When I try to install the cert manager I get the following error message in the end:

Something went wrong while installing Cert-Manager

* Operation failed. Check pod logs for install-certmanager for more details.

The pod log looks mostly fine and contains a

cert-manager has been deployed successfully!

but short after this, when it tries to create the cluster issuer its just outputting errors.

+ seq 1 90
+ kubectl apply -f /data/helm/certmanager/config/cluster_issuer.yaml
The ClusterIssuer "letsencrypt-prod" is invalid: metadata.managedFields.fieldsType: Invalid value: "": must be `FieldsV1`
+ s=1
+ sleep 1s
+ echo 'Retrying (1)...'
+ kubectl apply -f /data/helm/certmanager/config/cluster_issuer.yaml
Retrying (1)...
The ClusterIssuer "letsencrypt-prod" is invalid: metadata.managedFields.fieldsType: Invalid value: "": must be `FieldsV1`
+ s=1

And this goes up to Retrying (90)

I’m running a k3s cluster on version 1.18

Client Version: version.Info{Major:"1", Minor:"18", GitVersion:"v1.18.3", GitCommit:"2e7996e3e2712684bc73f0dec0200d64eec7fe40", GitTreeState:"archive", BuildDate:"2020-05-22T20:04:08Z", GoVersion:"go1.14.3", Compiler:"gc", Platform:"linux/amd64"}
Server Version: version.Info{Major:"1", Minor:"18", GitVersion:"v1.18.3+k3s1", GitCommit:"96653e8d86b74a1f73eadf09d4edc44778c2f8dd", GitTreeState:"clean", BuildDate:"2020-06-01T16:47:11Z", GoVersion:"go1.13.11", Compiler:"gc", Platform:"linux/amd64"}

Has someone run into a similar issue and solved it or has an idea what/who exactly is responsible for this error?

1 Like

The same error.
gitlab-ee 13.0.6-ee.0 and 12.10.11-ee.0.
Any solution?

1 Like

Same issue here.

13.1.0-pre 22c70dcc01f

k8s 18.2 on Azure

1 Like

Currently, GitLab supports the following Kubernetes versions:
• 1.16
• 1.15
• 1.14

Downgrade k8s version to solve problem.

@sem_p that’s kinda offtopic here.

We are not talking about hosting gitlab on kubernetes but deploying a pod it via the kubernetes integration and gitlab Auto-Devops images. According to the docs any stable version beyond 1.16 is supported for that:


Nvtl. downgrading should never be the first option when talking about stable software releases. As such you have to consider version 1.18.x of k8s.
It worked before so I would rather consider it a bug. This thread has mainly the purpose on helping to debug the issue and the root cause. For a quick fix I would have created a ticket right away.


1 Like