Unable to load gitlab.com login page in web browser, Under Attack page redirect fails

I can’t log into Gitlab.com, which I use every day, all day, for work, on multiple projects.

  • I’m using Chrome, Version 83.0.4103.116 (Official Build) (64-bit)
  • I’m on Windows 10 Home, Version 1903, build 18362.900
  • I’m trying to access gitlab.com, not a self-hosted instance.
  • I can load the gitlab.com webpage fine in chrome, but when I go to this link: https://gitlab.com/users/sign_in?redirect_to_referer=yes it fails to load a webpage and gives me an error, see image below.
  • I’m not using a VPN on chrome
  • I have allowed chrome through the firewall
  • The problem suddenly arose after trying to setup Forestry.io for a Hugo site running on Gitlab Pages.
  • I happen to also have Brave installed, and by accident I’m still logged into Gitlab on that browser.
    • The repo I’m currently trying to access is also giving me an “An error occurred while fetching folder content.” error when loading the root of the project in Brave. I don’t know if this is related, but it seemed to begin at the same time.
    • I’m loath to mess with the Brave login unless I absolutely have to, because it’s my only backup plan if I don’t get help
    • It’s possible that Brave is using a different IP address or VPN, I don’t know a lot about it yet.
  • I wonder if I might have triggered some sort of DDOS protection or rate limit by using Forestry.io
  • I’ve already run windows diagnostics. No problems found.
  • No other websites are affected.
  • Not warnings are displayed to me generally that might indicate a ban or rate limit, when viewing the account from Brave.
  • I’ve already cleared my Chrome cache, and that didn’t help.
  • I’ve tried a hard refresh (ctrl+F5), no luck
  • The login issue persisted even when I tried to use Gitlab authentication to sign up for this very forum.
  • At no point am I permitted to even enter my credentials into the site, when viewed through chrome, so no, it’s not that I forgot my password.
  • I’ve tried restarting my computer.

I’ll gladly answer any questions to get this resolved.

The repository in question is this one: https://gitlab.com/arcandio/hugo-arc

It turns out that all of my repositories are showing this error in Brave right now.

I can still fetch repositories, though I think that Forestry.io reset my repo’s remote origin url to SSH instead of HTTPS, which I had to then reset.

I can still push to repositories, apparently.

Must have been some sort of rate limit, I can access the login page and have logged in on chrome.

Sometime this type of error comes due to time/timezone issue.

I’ve had this exact same issue again, I think because I committed to that repository that’s connected to Forestry. I believe that Forestry’s connection is what screws up my ability to use Gitlab, because it’s the only thing connected to the one account that coincides with this problem. Unfortunately, I can’t log into Forestry because I can’t log into Gitlab, and if I could, I don’t think they have an option to remove sites. I don’t know if they even have a forum. Once I get back into gitlab, I’ll have to try some things:

double-check timezone setting on Forestry. There isn’t one on Gitlab, so I don’t know what there is to produce a timing collision like this.
remove all outgoing connections from the repo
contact any support for Forestry and get them to remove my account or sites
Possibly migrate my repository to Github instead of Gitlab to even get it to work again.

Any support whatsoever from the Gitlab side would be great.

Now I also cannot push to my repositories.

image

I just talked to the Forestry slack channel, and it seems like this is more a problem on Gitlab’s end. I’m seeing a lot of this sort of behavior on this repo, regardless of whether I’m logged in or not.

Hi @arcandio - thank you for providing such detailed information. It’s likely you are being affected by the events spelled out in this issue:

We are working hard toward resolution; thank you for your patience! I’ll try to give an update here as soon as I see progress, but feel free to follow along in the linked issue above. Thanks again! Talk soon :blush:

Thanks @Linds, I think I saw something about this incident when I checked Gitlab Status yesterday, but I think at the time I wasn’t sure if the timing matched up or if the behavior matched up. Looks like it matches up pretty well though, so I’ll keep an eye on that issue, though I understand about 1 word in 8. Well, at least it’s not something wrong with my repo or account.

1 Like

For my clarification, did I bring this up in the right place? Or should I have tried to report this as a bug, however Free users do that?

I think you chose as good a place as any! I have tagged this thread with the known-issue tag. That might help with the organization in the future. :blush: Thanks for asking!

1 Like