Unable to login on gitlab.com: "Login failed. Please retry from your primary device and network."

So I got stuck trying to login today as well. Clicking the fields, retyping a letter, typing manually, deactivating adblock - nothing worked. In the end, the only thing that worked was using a different browser entirely.

Can y’all get this fixed already? This is freaking ridiculous.

1 Like

@Brancieq-Paul @DaJay42 Which browser / browser plugins (especially adblockers) are you using?

I’m having the same issue. None of the proposed fixed have worked for me either

1 Like

TLDR/Possible Fix: Clear cookies and try to log in again.

I just had this happen on my PC. On my laptop and smartphone I was able to log in without issue.
I did check DevTools and saw two errors. One was pretty much the same as in zoikellis post. The other one was what zoikelli mentioned aswell: a violation of CSP followed by a list of some Gitlab and a bunch of AWS subdomains. If I remember correctly this was caused by OtAutoBlock.js / cookielaw.org.

I cleared cookies for Gitlab via DevTools and was able to log in.

Hi,

I am having the same issue, could you please have a look? I tried clearing cookies and cache, didn’t seem to help.
This is a bit of an urgent request as I need my Gitlab account to access a limited time coding assessment project.

Sincerely,

1 Like

Hi @whaber ,

UPDATE: I was able to login by opening an incognito chrome without ANY plugins running. after successfully logging in, also with 2FA, the new login location was enabled and I was able to login normally from other browsers in normal mode with plugins installed.

I am traveling abroad and can’t login to gitlab! It is urgent that I login to work! please allow me to login.

I see the following message:

Login failed. Please retry from your primary device and network.

Kind regards

1 Like

Hi @dciccale The forum is not intended for specific issue escalation as it is intended for general discussion. I recommend you file a support ticket for our support team Support

Apologies that you are having this issue. The support team is the best team to analyze and help resolve what you are seeing.

1 Like

Hi, I have a similar issue, i can not create an account, i recive the response " 1 error prohibited this user from being saved:" i have changed user and i have changed browser but no change the response

Also having this issue on Brave with DashLane password manager. Getting the following message:

Login failed. Please retry from your primary device and network.

No captcha was presented. Is there some way to disable this “feature” so that we can actually log in to our accounts?