Unable to merge

All of a sudden I seem to be unable to merge any merge request from the Gitlab web interface. The green Merge button is there, and when I click it the busy spinner appears. But after that nothing. No error messages or anything, and the merge requests stays open. Fetching, pulling, pushing etc. all works normal as before.

I’m not sure if it is related to it, but I updated Gitlab from version 8.17.2 to 9.2.5 last week. Update to 9.2.7 today made no difference.

I’m running Gitlab on a Ubuntu 16.10 server.

Can anyone give any suggestions on how to troubleshoot this? Any logs I might examine to see if there are any errors hidden inside?

1 Like

I have found a little more information by now. It seems like my sidekiq processes are crashing all the time, preventing the Gitlab queues to be processed. Looking in the Background jobs page in the Monitor I see 44 jobs enqueued, and the message that no sidekiq process is running. When checking the sidekiq log I see a new process starting every 5 seconds. Starting with the message “A JSON text must at least contain two octets!”.

Is it possible that sidekiq crashes on a specific queue job, and therefore never processes everything that comes afterwards? How can I tell which job is causing those problems?

1 Like

I have the same issue on gitlab.com
the merge start but then it says
This merge request is in the process of being merged, during which time it is locked and cannot be closed.
forever

1 Like

The merge request got stuck but still merged the code into the other branch. Saw the commit in the other branch.

Does anyone know if it is safe to delete some jobs from the queue, and see if that solves the problem? Having a broken Gitlab installation is not really a workable situation at the moment.

In the end I solved it by creating a backup, remove gitlab, reinstall, and restore the backup.

So problem solved now.