Unable to mount img in CI

Background

I am attempting to build a modified Archiso in a container. However, I get an error about mounting the image when I run the build script:
mount: work/efiboot: failed to setup loop device for /builds/frc-team-4739/managment/ffos/work/iso/EFI/archiso/efiboot.img.

Note that I am using gitlab.com which I assume is running the latest stable.

Reproducing

Despite the build script being used for building a customized iso, not applying any optimizations and building the stock iso breaks.

.gitlab-ci.yml (https://bbs.archlinux.org/viewtopic.php?id=243393)

image: archlinux

stages:
    - build

make-iso:
    stage: build
    before_script:
    - pacman --noconfirm -Syu archiso
    script:
    - cp -r /usr/share/archiso/configs/releng/ ./live-usb
    - ./live-usb/build.sh -v

Troubleshooting

I attempted make the container priverlaged with config.toml as suggested here, with the meathod as suggested here; but didn’t seem to do anything:

[runners.docker]
    privileged = true
  • The first result for my question on Google was this, but it gives a 404 despite the preview looking promising
  • I attempted to reverse this apparently working container for building Archiso, but things were about the same as what I already had

I had found this repo which works on their repo, but when I copy in the files it fails. With the same error.

I have wasted half a week trying to fix this issue and I have had no luck. It seems as through the only option is to run another server for building which is expensive and annoying to administrate. Is there any reason why I am not able to do these operations, I can see that is related to security in some way, but why is there no way to disable or bypass that?