Unable to start Gitlab on Docker after moving /var/lib/docker

I have a docker CE GitLab 16.4.1 install.
I currently have 2 partitons (/ and /home) both ext4, rw mounted.
/ is too small and I cant resize it for now. So I need to move /var/lib/docker (the biggest folder) to /home.
I stopped docker, copied data (with cp -a to include all attributes), created symlink to new folder but I got

Checking for unmigrated data on legacy storage Upgrade failed. Could not check for unmigrated data on legacy storage. system temporary path is not writable: /tmp /tmp is not writable: /tmp . is not writable: /opt/gitlab/embedded/service/gitlab-rails rake aborted! ArgumentError: could not find a temporary directory /opt/gitlab/embedded/service/gitlab-rails/config/initializers/7_prometheus_metrics.rb:44:in <top (required)>’ /opt/gitlab/embedded/service/gitlab-rails/config/environment.rb:7:in <top (required)>' <internal:/opt/gitlab/embedded/lib/ruby/site_ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:38:in require’ internal:/opt/gitlab/embedded/lib/ruby/site_ruby/3.0.0/rubygems/core_ext/kernel_require.rb:38:in require' /opt/gitlab/embedded/bin/bundle:25:in load’ /opt/gitlab/embedded/bin/bundle:25:in <main>' Tasks: TOP => gitlab:storage:legacy_attachments => environment (See full trace by running task with --trace)

I tried:

  • Exec bash and touch files in /tmp in the contianer (worked)
  • Use a symlink to a copy of the folder in / (worked)
  • Set the directory in /etc/dockerd/deamon.json to my /home copy (did not work, same result)

Does anyone have any idea ?

Update:
It now seems to work, I dont really know why.
I redo same steps a lot of times but this time all work…