Unable to update docker from 13.12.12 to 14.0.0

As it states above I have not been able to update from 13.12.12 to 14.0.0. I verified unicorn wasn’t running, I don’t have unicorn or puma in my gitlab.rb. I have been going crazy over this. I have tried to look at background migrations and nothing. Now I cannot even revert to 13.12.12 or I get a login screen and then a server error after authenticating. I am stuck… My docker-compose logs gitlab gives this:

gitlab         | Running handlers:
gitlab         | Running handlers complete
gitlab         | Chef Infra Client finished, 33/716 resources updated in 12 seconds
gitlab         | gitlab Reconfigured!
gitlab         | Checking for unmigrated data on legacy storage

It has been like that for well over 3 hours this time alone. I have tried reconfigure, I have tried to check for migrations, I have run the command to migrate data to hash. Nothing allows it to come up.

Bumping for assistance

Have a look to my topic:

but be careful, I’m updating in a docker environment, so I could restore my backup many times for all the testing.I suggest you to move to Docker too. It’s not that hard:

good luck !

I didn’t have anything too important on it so that I just plan to delete and start over.