Unable to update Gitlab EE with Curl Error #35 on Centos 7

I have CentOS Linux 7.6.1810
I am running the Omnibus installation of Gitlab which is currently at version 11.2.3-ee (aadca99)
I have been unable to update for a few months now, due to an error with my yum repo.

https://packages.gitlab.com/gitlab/gitlab-ee/el/7/x86_64/repodata/repomd.xml: [Errno 14] curl#35 - "TCP connection reset by peer"
Trying other mirror.
https://packages.gitlab.com/gitlab/gitlab-ee/el/7/SRPMS/repodata/repomd.xml: [Errno 14] curl#35 - "TCP connection reset by peer"
Trying other mirror.

I thought maybe re-installing the repo would help, so I tried that and it also failed, so I ran curl with -vv to get information.

curl -vv https://packages.gitlab.com/install/repositories/gitlab/gitlab-ee/script.rpm.sh | sudo bash
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0* About to connect() to packages.gitlab.com port 443 (#0)
*   Trying
* Connected to packages.gitlab.com ( port 443 (#0)
* Initializing NSS with certpath: sql:/etc/pki/nssdb
*   CAfile: /etc/pki/tls/certs/ca-bundle.crt
  CApath: none
* TCP connection reset by peer
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
* Closing connection 0
curl: (35) TCP connection reset by peer

I’ve spent countless hours trying to track down a solution, I have no issues with other 3rd party repos like pgdg96 (postgres) or virtualmin. My best guess is that packagecloud.io only supports TLS v1.2 and that the default curl on CentOS doesn’t? If that’s the case, I’d thought I might find a lot of other people with the same issue, but I have not.

I am behind a firewall, no proxy, and I’ve moved this particular box into it’s own zone without any rules, so I’ve all but eliminated the firewall as a factor. Plus, why just packages.gitlab.com?

Any suggestions for what I can try? I can’t even curl/wget the RPM directly to do manual install.