* unicorn['svlogd_prefix'] has been deprecated during attempted upgrade to 14

I am hoping someone else has seen this and can point me in the right direction of what, and where, to make changes.

This is an ubuntu 18.04 LTS server currently running gitlab-ce 13.12.5-ce.0. It was dist-upgraded from 16.04 fairly recently and everything works as expected. Puma is running, unicorn is not. I get the following warning/error when running gitlab-ctl reconfigure or when trying to apt upgrade to version 14 (the default now).

Deprecations:

  • unicorn[‘svlogd_prefix’] has been deprecated since 13.10 and will be removed in 14.0. Starting with GitLab 14.0, Unicorn is no longer supported and users must switch to Puma, following Puma | GitLab.

The error makes sense other than the fact that I cannot find this setting anywhere in the configuration files or /opt/gitlab. There are no, uncommented “unicorn” settings in gitlab.rb and no default settings I can find that match. Is this hard coded somewhere or am I missing something?

Thanks!

Same issue here, cannot find any matching setting. Currently running 13.12.3-ee and was attempting to update to 14.x.

Hi @jimclark01 and @snappyslippers

Are either of you sending your UDP logs to another host by setting logging['udp_log_shipping_host']?

That setting ends up creating a unicorn['svlogd_prefix'] setting in the background - which creates the deprecation notice. There’s more background in this issue

We have an internal backport issue open for this to backport this Merge Request to the next 13.12.x release to unblock the upgrade.

In the meantime, we have some workarounds documented in the original issue.

Probably the best one is to temporarily set: logging['udp_log_shipping_host'] = nil in your gitlab.rb long enough to upgrade, and then set it back.

Can you give that a try and see if that works for you?

1 Like

Yes, I have a remote logging host set:

logging[‘udp_log_shipping_host’] = ‘loghost’
logging[‘udp_log_shipping_port’] = 514

commenting out those two lines and running gitlab-ctl reconfigure removed the deprecation error and I successfully apt updated to version 14.0.1. Things look good at this point and I have marked this as solved.

Appreciate the prompt assistance!

1 Like