Update asap is wrong

Seemed easy, take a backup, then run the the update because of the ‘asap’ message. Main reason for doing this as well is because i’m migrating to another server. The other server is on the latest, 10.8.4, so that’s what I expect the old server to be at. However, after the update was complete, I pressed on even though the ‘asap’ message was still there. Needless to say, the restore failed as it says the version were incompatible - ie I was restoring from a 10.8.2 to a 10.8.4. So I went back to the original and tried to run the update again, and got this “Package gitlab-ce-10.8.4-ce.0.el7.x86_64 already installed and latest version”. So, why does the backup restore version think it is 10.8.2, and why is the update asap still there when there is nothing to update? ie, what am i missing… (oh, and for good measure, why does it say in the admin page I’m at 10.8.1…very annoying.
Also, if I run this sudo gitlab-rails console, it says 10.8.4 on BOTH, so somebody is lying.

Sorry, dunno where it all went wrong (but then again if i had to guess I probably had too many backups in the folder) but all is well now. I successfully restored the backup to the new server. (Old one still says ‘update asap’, but I could care less not as I’m going to wipe it out anyway)