Update to 11.11.4 on Bionic

Hi, I am using gitlab 11.9.8-ee

I tried to update dirrectly to the last release but I have the following error message

gitlab preinstall: It seems you are upgrading from 11.x version series
gitlab preinstall: to 12.x series. It is recommended to upgrade
gitlab preinstall: to the last minor version in a major version series first before
gitlab preinstall: jumping to the next major version.
gitlab preinstall: Please follow the upgrade documentation at https://docs.gitlab.com/ee/policy/maintenance.html#upgrade-recommendations
gitlab preinstall: and upgrade to 11.11 first.

So I am trying to install gitlab 11.11.4

lsb_release -a returns

No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 18.04.1 LTS
Release:	18.04
Codename:	bionic

So I am getting the version for bionic

wget https://packages.gitlab.com/gitlab/gitlab-ee/packages/ubuntu/bionic/gitlab-ee_11.11.4-ee.0_amd64.deb

then

dpkg -i gitlab-ee_11.11.4-ee.0_amd64.deb

But I have the folowing error message

dpkg-deb: error: 'gitlab-ee_11.11.4-ee.0_amd64.deb' is not a Debian format archive
dpkg: error processing archive gitlab-ee_11.11.4-ee.0_amd64.deb (--install):
 dpkg-deb --control subprocess returned error exit status 2
Errors were encountered while processing:
 gitlab-ee_11.11.4-ee.0_amd64.deb

The error message suggests that it’s not a debian package you’re trying to install.

Why are you downloading deb-files and installing them via dpkg instead of configuring an apt source and use apt?

What does file gitlab-ee_11.11.4-ee.0_amd64.deb give you?

Hi @ajouve,

It sounds like wget did not download a .deb file but actually saved <html> output in a 12Kb file named gitlab-ee_11.11.4-ee.0_amd64.deb. This is why you’re getting the dpkg error.

The easiest way to manage updates and get the latest GItLab versions is to use our installation instructions to add the GitLab EE repository to your apt sources.

curl https://packages.gitlab.com/install/repositories/gitlab/gitlab-ee/script.deb.sh | sudo bash

After adding the repository, you can upgrade to specific versions as follows:

sudo apt-get install gitlab-ee=11.11.4-ee.0

If you do not want to add a repository to your system, you can follow wget instructions for specific packages versions:

wget --content-disposition https://packages.gitlab.com/gitlab/gitlab-ee/packages/ubuntu/bionic/gitlab-ee_11.11.4-ee.0_amd64.deb/download.deb

followed by

apt install ./gitlab-ee_11.11.4-ee.0_amd64.deb

or

dpkg -i gitlab-ee_11.11.4-ee.0_amd64.deb

Hope this helps!

3 Likes

Thanks… this solved the issue for me. A direct link to this version on the upgrade page that one sees in the package update error message would be awesome.

I had to Google to get to this page :pensive: