Updrading GitLab from 13.5.4 to 13.8.8

Hello, I have GitLab 13.5.4 installed in my CentOS 7 server using an external NGINX server.

I was working this way for years, however, since yesterday I cannot load the UI. The produced error is 502, Bad Gateway.

In order to stop fighting with this error, I decided to upgrade it.

Since I have installed the system using yum utility, I tried to upgrade to 13.8.8 version first using this command:

yum install gitlab-ce-13.8.8

After some seconds, and displayed several messages, installation failed with this error:

gitlab preinstall:
gitlab preinstall: Database backup failed! If you want to skip this backup, run the following command and try again:
gitlab preinstall:
gitlab preinstall:  sudo touch /etc/gitlab/skip-auto-backup
gitlab preinstall:
error: %pre(gitlab-ce-13.8.8-ce.0.el7.x86_64) scriptlet failed, exit status 1
Error in PREIN scriptlet in rpm package gitlab-ce-13.8.8-ce.0.el7.x86_64
Verifying  : gitlab-ce-13.8.8-ce.0.el7.x86_64                                                                                                  1/2
gitlab-ce-13.5.4-ce.0.el7.x86_64 was supposed to be removed but is not!
Verifying  : gitlab-ce-13.5.4-ce.0.el7.x86_64                                                                                                  2/2
gitlab-ce.x86_64 0:13.5.4-ce.0.el7                                        gitlab-ce.x86_64 0:13.8.8-ce.0.el7

Database could not backed up. Of course I don’t want to skip that backing up process.

I tried to manually back up the database using command gitlab-backup create. After a few seconds, this message appears:

[root@node gitlab]# gitlab-backup create
/usr/bin/gitlab-backup: line 69: 26978 Killed                  /opt/gitlab/bin/gitlab-rake gitlab:backup:create ${@}
[root@node gitlab]#

In summary, I cannot do anything with my GitLab installation. Neither loading the current version UI nor upgrading it to a current version.

Can anyone help me, please?