Upgrade 10.7.3 to 11.0 fails with HTTP-Error 500 and yaml-parser


#1

Hello everybody,

on the weekend I tried to upgrade our Gitlab-Server (Based on Ubuntu 16.04) via apt-get (Ommnibus-Method I understand?).
apt-get dist-upgrade went fine from what I can say, but afterwards I received an HTTP-500-Error when browsing to the webpage of our gitlab.

After some googling I ran gitlab-ce reconfigure and was met with the following error:

templatesymlink[Create a smtp_settings.rb and create a symlink to Rails root] (gitlab::gitlab-rails line 241) had an error: TypeError: link[/opt/gitlab/embedded/service/gitlab-rails/config/initializers/smtp_settings.rb] (/opt/gitlab/embedded/cookbooks/cache/cookbooks/package/resources/templatesymlink.rb line 58) had an error: TypeError: no implicit conversion of nil into String

I am sorry I can not provide anymore details, as I needed to get the server at least functional again (restored snapshot from before the upgrade; so old gitlab-version 10.7.3).

Since this is a production with high demand I can only upgrade on the weekends, so providing information can maybe take some time.

Nevertheless I am grateful for any help.


#2

I had issues upgrading as well, not the same as you.

But I had success when I upgraded to the last of the 10 series. Then upgrading again to 11.


#3

I had exactly the same error. For me it was because the update just did not want to work, if there is the file “smtp_settings.rb”. Renamed this file fixed the issue for me:
sudo mv /opt/gitlab/embedded/service/gitlab-rails/config/initializers/smtp_settings.rb /opt/gitlab/embedded/service/gitlab-rails/config/initializers/smtp_settings.rb.bak

Afterward, either the update can be retried, or, if the update has already gone wrong, a reconfigure of GitLab can be triggered:
sudo gitlab-ctl reconfigure

After successfully update, you can rename the file smtp_settings.rb.bak back to smtp_settings.rb and mail still work.

If necessary, you can also update GitLab to an intermediate version before you go to the latest version. For example by running this command:
sudo apt install gitlab-ce=10.8.5-ce.0

Hope this fixed your issue.


#5

Thanks a lot for the replies.

I will try this later.
Sorry for the late reply, as you can imagine there is other stuff on my desk :wink: