Upgrade from 6.8.1 to 7.8.4 failed - rollback worked, almost

Hi. I’ve been running 6.8.1 for awhile and decided to upgrade to 7.8.4. Aside from the fact that 7.8.4 didn’t work, I followed the steps carefully and managed to restore my 6.8.1. All seems well, except for basically the SAME problem I had with 7.8.4.

I installed gitlab_6.8.1-omnibus.4-1_amd64.deb on my Ubuntu 14.04.2 LTS Server Virtual machine.

If any additional logs are needed, please don’t hesitate to ask. Existing projects still work (thanks to my gitlab_backup.tar")

When I create a project, all looks well, but I can’t connect to it with either SSH or HTTP. When I look in the admin area, it states that the repository “does not exist”. I also can not “destroy” the project. The “sidekiq.log” has a lot of:

1975.2015-05-18_15:46:26.93884 2015-05-18T15:46:26Z 935 TID-klp40 ERROR: Permission denied - connect(2)

1976.2015-05-18_15:46:26.93888 2015-05-18T15:46:26Z 935 TID-klp40 ERROR: /opt/gitlab/embedded/service/gem/ruby/1.9.1/gems/redis-3.0.6/lib/redis/connection/ruby.rb:149:in `connect_nonblock’

Can you try and run this command?

sudo gitlab-rake gitlab:satellites:create

There’s some new info regarding this in the docs http://doc.gitlab.com/ce/raketasks/backup_restore.html

Tried it. Skipped the bad ones. Afterward, I still couldn’t delete them or do anything.

WARNING: Nokogiri was built against LibXML version 2.8.0, but has dynamically loaded 2.7.8
Creating satellites for …
BaseLibrary / CppLibrary … exists already
LinuxKernel / linux-cubox-i … skipping, because the repo is empty
LinuxKernel / linux-hummingboard … skipping, because the repo is empty
Hardware / gpio … skipping, because the repo is empty
Ken / test1 … skipping, because the repo is empty

Somehow, my repos aren’t being created. I think that is the underlying problem. Exactly how and where they are being created, and where is the log showing the attempt, I haven’t got a clue. I also suspect that is why my 7.8.4 failed, as well. Important info gets pushed into the db, but can’t be read, because it didn’t make it… :smile: I know less than nothing about postgresql.