Upgrade from gitlab 11.10.4 (62c464651d2)

I am running gitlab-ce on a Ubuntu-Server 18.04
Everything uptodate, tried to upgrade with “apt-get install gitlab-ce”, but it is already newest version.
In the admin-panel of gitlab it shows me i should update asap.
Can somebody please explain or tell me how to update gitlab right?
Thank you very much!
Output of sudo gitlab-rake gitlab:env:info

System information
System: Ubuntu 18.04
Current User: git
Using RVM: no
Ruby Version: 2.5.3p105
Gem Version: 2.7.6
Bundler Version:1.17.3
Rake Version: 12.3.2
Redis Version: 3.2.12
Git Version: 2.18.1
Sidekiq Version:5.2.5
Go Version: unknown

GitLab information
Version: 11.10.4
Revision: 62c464651d2
Directory: /opt/gitlab/embedded/service/gitlab-rails
DB Adapter: PostgreSQL
DB Version: 9.6.11

GitLab Shell
Version: 9.0.0
Repository storage paths:
default: /var/opt/gitlab/git-data/repositories
GitLab Shell path: /opt/gitlab/embedded/service/gitlab-shell
Git: /opt/gitlab/embedded/bin/git

Apt-get can only upgrade to versions it knows about, meaning versions that were in a configured repository the last time you ran apt-get update (or just apt update).

Download https://packages.gitlab.com/install/repositories/gitlab/gitlab-ee/script.deb.sh, read it to make sure it’s not been replaced by a malicious script (which is a reason you should never execute curl ... | sh-style commands, even though they are frequently seen in guides), and either run it or deduct the proper path to the gitlab repository it wants to add, and add it to /etc/apt/sources.list (or a file in sources.list.d).

Then normal commands should work.

1 Like

so you mean i should use the script or search for the right git-repository for upgrading and put it into the source.list, right?
So i have to search for the repository for gitlab-ce-version 11.11.3 first, then for version 12?
then again “apt-get update && apt-get install gitlab-ce”?

All the versions (quite some way back, far enough to cover your needs at least) are in one repository. So adding the repository is a one time task.

But as apt-get tells you that you have the newest version, when you don’t, it looks like you haven’t done that.

1 Like

ok i executed the script and the script worked well, but now after “apt-get update” and then “apt-get install gitlab-ce” i get this error:

so i think i have to update to 11.11 first, right?
so now i have to do “apt-get install gitlab-ce” with “=version”?

it literally tells you what to do in the command output. And yes, you now have to first upgrade from your current 11.10.4 to 11.11.8, then from 11.11.8 upgrade to 12.0.12 and then from that upgrade to latest (currently 12.10.2)

Source: https://docs.gitlab.com/ee/policy/maintenance.html#upgrade-recommendations

Please do NOT do any of this, before anyone else confirms that this is the correct procedure.

Furst of all: NEVER post text as images! Three reasons (what I could just remember, there might be more, but there are none the other way):

  1. It requires extra work to view
  2. They’re not searchable
  3. They are not screen-reader friendly (some people use that)

As @aljaxus says: “it literally tells you what to do in the command output”, why don’t you just do that instead of complaining here? Makes you seem pretty clueless.

It even seems you know the apt(-get) syntax to upgrade to a particular version.


ok thank you, i will try that in the next days!
And sorry for the image issue!
I just wanted to get it approved, because i wanted to be sure :sweat_smile:
And yes i upgrade a gitlab server for the first time, so i just don’t want to make anything worse.
Thank you again.