Upgrade gitlab gitlab-ce-13.10.3-ce.0 to latest 14.x failing

Attempting to upgrade gitlab-ce-13.10.3-ce to the latest available, which according to yum is gitlab-ce-14.3.0-ce.0.

I’m reading Upgrading GitLab | GitLab and there is no specific path from 13.10.3 → 14.x
If I do a yum install gitlab I’m getting:

 sudo yum install gitlab-ce
Last metadata expiration check: 0:00:17 ago on Wed Sep 29 15:03:20 2021.
Package gitlab-ce-13.10.3-ce.0.el8.x86_64 is already installed.
Dependencies resolved.
 Package                         Architecture                 Version                               Repository                              Size
 gitlab-ce                       x86_64                       14.3.0-ce.0.el8                       gitlab_gitlab-ce                       917 M

Transaction Summary
Upgrade  1 Package

Total download size: 917 M
Is this ok [y/N]: y
Downloading Packages:
gitlab-ce-14.3.0-ce.0.el8.x86_64.rpm                                                                              97 MB/s | 917 MB     00:09
Total                                                                                                             97 MB/s | 917 MB     00:09
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                                                         1/1
  Running scriptlet: gitlab-ce-14.3.0-ce.0.el8.x86_64                                                                                        1/2
gitlab preinstall: It seems you are upgrading from major version 13 to major version 14.
gitlab preinstall: It is required to upgrade to the latest 14.0.x version first before proceeding.
gitlab preinstall: Please follow the upgrade documentation at https://docs.gitlab.com/ee/update/index.html#upgrade-paths
error: %prein(gitlab-ce-14.3.0-ce.0.el8.x86_64) scriptlet failed, exit status 1

Error in PREIN scriptlet in rpm package gitlab-ce
  Verifying        : gitlab-ce-14.3.0-ce.0.el8.x86_64                                                                                        1/2
  Verifying        : gitlab-ce-13.10.3-ce.0.el8.x86_64                                                                                       2/2

  gitlab-ce-13.10.3-ce.0.el8.x86_64                                       gitlab-ce-14.3.0-ce.0.el8.x86_64

Error: Transaction failed

When I ‘dnf search gitlab’ the only gitlab-ce being returned from search is gitlab-ce-14.3.0-ce.0 deom the gitlab_gitlab-ce repo

Any advice?


Hi, follow the upgrade path and do the upgrade like this:

dnf install gitlab-ce-13.12.12-ce.0.el8

latest 13.12.Z latest 14.0.Z latest 14.Y.Z

so for you latest 13.12.x release first, before you then go to latest 14.0.x release. I suggest then, since others have had issues is to then upgrade to latest 14.1.x release, then 14.2.x release, then finally to 14.3.0.

For exact package name format and to find out exactly what the latest version number is for the dnf command, check here (I’ve prepared the search to filter for el8 for you): gitlab/gitlab-ce - Results for 'gitlab-ce-14' and el/8 in gitlab/gitlab-ce

Upgrade procedure more or less is:

  1. Upgrade to the version you need as written above.
  2. Check background migrations: Upgrading GitLab | GitLab and make sure it returns 0 before continuing next upgrade.

Then repeat as necessary until on 14.3.0

1 Like

Thank you very much!
That ‘worked’ - I was able to upgrade to latest, but w/o breakage. I searched the forum and had to ‘fix’ with:

sudo gitlab-rake db:migrate

after I saw in the logs:

ActiveRecord::StatementInvalid (PG::UndefinedTable: ERROR: relation "project_topics" does not exist
LINE 8: WHERE a.attrelid = '"project_topics"'::regclass

I say ‘fix’ because command line pushes haven’t worked until I ran:

sudo gitlab-rake restart

Now, command line is running, but from my browser, when looking at a repo, I’m seeing:

An error occurred while fetching folder content.

In Chrome’s Dev Tools it seems to be hanging on graphql

Any ideas on the ‘error while fetching folder content?’ I see a lot of postings about that, but so far haven’t found a resolutions


I fixed it by running:

sudo gitlab-ctl restart

Thanks for your help

1 Like

latest 13.12.Z latest 14.0.Z latest 14.Y.Z

Perhaps worth mentioning going from 13.12 → 14.0.0 → latest 14.Y.Z did not work for me. I wrote about it here. It seems you really do need to make that middle jump latest 14.0.Z (which I was not aware of). As it stands my deployment hosting hundreds of users is presently broken.