Upgrade to GitLab 15.9.3 failing with "dpkg error processing archive"

I have a relatively new 15.9.2 instance of GitLab running on Ubuntu Server 22.04 LTS, installed using the apt package manager. Now I’m using apt to upgarde to 15.9.3 and I’m getting an unexpected error.

1 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
5 not fully installed or removed.
Need to get 0 B/1348 MB of archives.
After this operation, 9216 B of additional disk space will be used.
(Reading database ... 176243 files and directories currently installed.)
Preparing to unpack .../gitlab-ee_15.9.3-ee.0_amd64.deb ...
Public attributes file is missing, run gitlab-ctl reconfigure to re-create it.
dpkg: error processing archive /var/cache/apt/archives/gitlab-ee_15.9.3-ee.0_amd64.deb (--unpack):
 new gitlab-ee package pre-installation script subprocess returned error exit status 1

Any ideas how to troubleshoot this issue?

I ran sudo gitlab-ctl reconfigure and then tried upgrading, and got past this error.