Upgrading Azure CE VM from 8.6.5

Hi,

I’ve had a search of the forums and I’ve not been able to find an answer, but if I’ve missed something please point me in the right direction.

I am using the Azure VM GitLab-CE template in my environment and I’ve noticed that it comes with version 8.6.5. Using this Gitlab article I’ve tried to upgrade the version but it’s broken it. A bit more reading I understand its to do with a change in datadase and the recommended upgrade path is to hope to 9.x first. The bit I am stuck on is how to do this with the Azure VM, as I’ve not installed the product I’m not familiar with how it was installed. If someone can provide me with the correct command to upgrade it to 9.x that would be great. As the current VM is busted I am planning to scrap it and deploy a new one so it’ll be a fresh install, hopefully that’ll make things easier.

Thanks
Rob

Rob, I ran into the same problem upgrading GitLab-CE 8.6.5 when running on Azure. Fortunately you can upgrade if you perform the upgrade in two steps and upgrade to version 9.4.0 first.

sudo apt-get update
sudo apt-get install gitlab-ce=9.4.0-ce.0
sudo apt-get install gitlab-ce

Hope this resolves your problem, it did for me.

1 Like

Many thanks for the reply, I did manage to finally work it out in the end but I am sure your reply will help the next man/woman.

Cheers