Upgrading from Ubuntu 14.04 to 16.04

Hello everyone. Has anyone tried to upgrade Ubuntu 14.04 with GitLab 8.x to Ubuntu 16.04? Will it break GitLab CE?

Thanks!

1 Like

I was able to update without too many issues. Here are the steps I used:

do-release-upgrade

This upgrades Ubuntu to Xenial 16.04 LTS. Once the upgrade is complete, reboot.

Your gitlab repository was automatically disabled during the upgrade. You’ll have to edit your repositories to add the correct gitlab repository. To do this, simply edit the file at /etc/apt/sources.list.d/gitlab_gitlab-ce.list and uncomment the 2 last lines (the ones that start with deb). Make sure they look like this:

deb https://packages.gitlab.com/gitlab/gitlab-ce/ubuntu/ xenial main 
deb-src https://packages.gitlab.com/gitlab/gitlab-ce/ubuntu/ xenial main

Next, run the following commands

gitlab-ctl reconfigure
apt-get update
apt-get upgrade
gitlab-ctl restart

You should be good to go now. Everything works as expected and I haven’t run into any issues yet

6 Likes

Thank you very much for your respond and step by step instructions. I really appreciate it. Will try it later today :smile:

First off thanks for outlining the steps you used to upgrade to 16.04 LTS.

However I would highly recommend NOT using the command do-release-upgrade -d to start the upgrade process and instead simply use do-release-upgrade. If you use the -d switch you may find yourself running a development version of Ubuntu instead of the latest stable version.

https://help.ubuntu.com/lts/serverguide/installing-upgrading.html

1 Like

I agree. Don’t use do-release-upgrade -d anymore. Instead, use do-release-upgrade (No -d switch)
When I posted my instructions, Ubuntu 16.04 hadn’t been out long enough so do-release-upgrade was not finding the new version yet. So, at that time, the only way to upgrade was to use the -d switch to force the upgrade.

I’ve updated my post to get rid of the -d switch

I just wanted to reply that this worked perfectly for me upgrading my dedicated-to-gitlab Ubuntu 14.04 VM.

2 Likes

Also chiming in with a zero-issue upgrade per steps. Thank you @rayperea.

2 Likes

Still works like a charm. Thank you kind.

2 Likes

Also had no problem using do-release-upgrade

2 Likes

I’ve upgraded gitlab-ee to 16.04 on corporate VMware server. No problems with do-release-upgrade.

2 Likes

Upgrade 16.04 → 18.04 following same steps also went fine!

1 Like