Usage Quotas do not correspond to reality

Hello,

Gitlab version: 15.4 (installed locally)

I have a problem with the available quota on my project.

Gitlab tells me that the project contains more than 26 GB of Artifacts.
However, there are no artifacts left on this instance (everything has been cleaned up and checked via the various commands found in the Gitlab documentation).

Worse still, my VM’s disk contains only 15 GB of data in total. So there can’t possibly still be 26 GB of artifacts.

I’ve already tried quite a few things, but I can’t seem to get any up-to-date remaining quota information.
Gitlab really thinks that this space is being used up because it’s preventing me from working because the space would be full.

Could you please help me?

Thanks in advance

Hi @ramodjo ,

There’s been a lot of development to make Usage Quota more accurate and usable since 15.4, including many bug fixes and improvements.

I suspect upgrading to the latest version of GitLab will fix most if not all of the issues you’re having. The upgrade path for 15.4 > latest can be found here: Upgrade Path

Hello and thanks for this reply

I had looked at the release notes and found no information about this kind of problem, so I had temporarily put this aside as a solution, but I’ll see if I can program it.

Thank you and have a nice day

Hello,

Unfortunately, the full update to the latest version (followed by a cleanup of artifacts) still hasn’t solved the problem :frowning:

Still over 26 GB of artifacts when there are none left at all :

image

I don’t know if it’s related, but it’s no longer possible to upload them either :

Thank you for any help you can give me.

Kind regards