Using dind in kubernetes runner with helm

I am encountering the TLS docker issue when deploying my gitlab runner to kubernetes with the helm chart. docs here

I solved this problem before doing --docker-volumes '/certs/client' in the gitlab-runner register command manually. But it seems that it is impossible to do that when using the kubernetes executor, since there is no docker-volumes value to configure in the chart. What am I supposed to do?

I would prefer to not have to use or manage custom certs. The chart can use certsSecretName but I would prefer not to have to create a secret, especially when I didn’t have to do anything like this for the regular docker executor.

I am getting errors like “Cannot connect to the Docker daemon” and “using http to connect to an https server”

I using with the latest runner version 13.2.2

I just want to do helm install -f values.yml and then be able to run docker in docker inside my runner. What is the minimum configuration needed for that?

Upgrading to 13.3.0 solved this issue for me:

Error response from daemon: Client sent an HTTP request to an HTTPS server.

But be sure to enable the gitlab runner with privileges ! :smiley:

try kaniko, it’s worked really well for me.

Thanks. I am new to kubernetes CI processes. Dind is just not the way to go. Kaniko is the solution here.

1 Like