Version '12.10.6-ce.0' for 'gitlab-ce' was not found

I am trying to upgrade my gitlab server to the latest version as recommended. I understand the upgrade paths, that you need to upgrade to the latest minor version before you upgrade to the latest major version.

I am currently running version 12.0.12 CE which means I should upgrade to 12.10.6 before going to 13.0.0 CE.

When I run

apt-get install gitlab-ce=12.10.6-ce.0

I get this error:

Version '12.10.6-ce.0' for 'gitlab-ce' was not found

Am I missing something? This worked for me last year when I upgraded my server. I am pretty sure that I ran this command last year to get to the version I am running now.

Why 12.10.6, the latest version is 12.10 is 12.10.11.

There is a 12.10.6 package, so it should work, one explanation would be that you haven’t actually configured the right repository, but there might be other explanations. If you use debian (or a derivative) show us the complete output of apt-cache policy gitlab-ce (there might be quite a lot of data,). If you use some other distribution, I’m not able to help.

I was updating to 12.10.6 because the upgrade recommendations suggested upgrading to that version to get to 13.2.0

When I try to upgrade to 12.10.11 I get the same message.

E: Version '12.10.11-ce.0' for 'gitlab-ce' was not found

here is the output from the command you asked me to run.

(I think that) 12.10.6 was the newest when the upgrade recommendations were written, that’s probably why they refer to that version. But there shouldn’t be any difference between 12.10.6 and 12.10.11 for upgrading, but if upgrading causes problems, it’s better (in almost all cases) to be on 12.10.11.

That output suggests that you have configured the repository. My first bet then is that you haven’t run apt update for a while. If that doesn’t help, please show us the output from running that command.

I run apt-get update before running apt-get install gitlab-ce=<LATEST-MINOR-VERSION>-ce.0

Here is the output when I run apt update

It looks like I don’t have a public key for gitlab? Where can I get this? Do you suppose that is like an ssh key?

So you missed that GitLab changed the key they use to sign repositories. There was a blog post about it:

That has a link to a guide on what to do.

Thanks that worked! Thank you so much. Got updated to 13.0.0

I tried to update to 13.2.0 per the upgrade recommendations but still got the message.

E: Version '13.2.0-ce.0' for 'gitlab-ce' was not found

I would stop here if it were not for the update asap message next to my servers version.

Version 13.2.0 has been released yet (expect it on 22 July), so what you’re experiencing now is supposed to happen. If I remember correctly there wasn’t even a 13.0.2 (publicly released version jumped from 13.0.1 to 13.0.3), but I also believe one of the later versions was labeled a security release, so you really should go to 13.0.6 (the latest).

Thanks man! I got everything working.